The InstantConference Outlook Add-On works with the Microsoft Windows and requires Microsoft Outlook 2003 or a more recent version of Outlook. The add-on does not work on Office for Mac computers.